View Issue Details

IDProjectCategoryView StatusLast Update
0000019The Underworld[All Projects] Bugpublic2020-03-16 00:45
ReporterSkyCorpAssigned To 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Versionr40 
Summary0000019: Expired (BMT) subscriptions don't show renew link right away
Description

There is no way to manually re-initialize a subscription in these cases (unless someone asks the subscribe URL)
A) Renew fails on monthly anniversary, but website still thinks subscription is still active for a few hours/days depending on when billing is attempted
B) The card has been changed mid-month and user just wants to take care of changing it over right away

Possible solution:
Always providing a manage subscription options link could resolve this? Inside that page, providing a manual renew link might be a good idea? But may have a risk of people accidentally double subscribing, so ensure warning and maybe link to BMT customer portal for people to double-check.

TagsNo tags attached.

Relationships

related to 0000050 confirmed Include the re-subscription link for active but unpledged Patreon backers 

Activities

SkyCorp

2020-03-01 05:26

administrator   ~0000075

Due to related bug fixes, BMT method now updates SkyCorp website to show optional resub link immediately on cancel. There is a similar issue that affects Patereon users, however, it is much more minor since users manage their subscription indirectly from Patreon.com. Will create a new issue for that and link here.

SkyCorp

2020-03-16 00:45

administrator   ~0000081

Game update r40 released!

Issue History

Date Modified Username Field Change
2019-09-03 21:28 SkyCorp New Issue
2019-09-03 21:29 SkyCorp Status new => confirmed
2020-03-01 05:25 SkyCorp Summary Expired subscriptions don't show renew link right away => Expired (BMT) subscriptions don't show renew link right away
2020-03-01 05:26 SkyCorp Status confirmed => resolved
2020-03-01 05:26 SkyCorp Resolution open => fixed
2020-03-01 05:26 SkyCorp Fixed in Version => r40
2020-03-01 05:26 SkyCorp Note Added: 0000075
2020-03-01 05:31 SkyCorp Relationship added related to 0000050
2020-03-16 00:45 SkyCorp Note Added: 0000081
2020-03-16 00:45 SkyCorp Status resolved => closed