View Issue Details

IDProjectCategoryView StatusLast Update
0000048The Underworld[All Projects] Bugpublic2020-03-16 00:45
ReporterChickenpie32Assigned ToSkyCorp 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformSWFOS.OS Version.
Product Versionr39 
Target VersionFixed in Versionr40 
Summary0000048: Cannot milk udder with milking machine without breasts
Description

I came across this issue while developing mods, but this is still present in vanilla.
If the player has a lactation udder, but no breasts, they will not be able to use a milking machine to drain the udder.

Steps To Reproduce

-obtain milker
-obtain breasts and lactating udder
-use reduce cream to remove breasts
-wait for udder to fill
-try to use milking machine

Additional Information

regaining breasts is not enough to fix this, as the breasts also need to lactating for the milker to work

the udder can still be milked using "milk self" if the player has usable hands

TagsNo tags attached.

Activities

SkyCorp

2020-01-13 03:59

administrator   ~0000061

Thanks for the bug report! Yep, looks like the milker code is set to only check breasts and not also udder. I'll need to be update it, along with the MILKER_USE flavor text that goes along with it.

SkyCorp

2020-02-26 05:44

administrator   ~0000072

Fixed in next build

SkyCorp

2020-03-16 00:45

administrator   ~0000083

Game update r40 released!

Issue History

Date Modified Username Field Change
2020-01-11 21:10 Chickenpie32 New Issue
2020-01-13 03:59 SkyCorp Assigned To => SkyCorp
2020-01-13 03:59 SkyCorp Status new => confirmed
2020-01-13 03:59 SkyCorp Note Added: 0000061
2020-02-26 05:44 SkyCorp Status confirmed => resolved
2020-02-26 05:44 SkyCorp Resolution open => fixed
2020-02-26 05:44 SkyCorp Fixed in Version => r40
2020-02-26 05:44 SkyCorp Note Added: 0000072
2020-03-16 00:45 SkyCorp Note Added: 0000083
2020-03-16 00:45 SkyCorp Status resolved => closed