View Issue Details

IDProjectCategoryView StatusLast Update
0000071The Underworld[All Projects] Bugpublic2021-08-16 22:59
ReporterSkyCorpAssigned To 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product Versionr40 
Target VersionFixed in Versionr41.3 
Summary0000071: Whoredra can decide to get tattoos/piercings that then cause AI to softlock
Description

Basically, one head got the “obedient pet” tattoo, and the other head refused to do anything other than try to fight to get money

Also visible when getting always naked band but trying to infinitely buy clothes

Steps To Reproduce

Via stitch-nose on discord:

1) become whoredra
2) Violet decides to get Tattoo
3) Violet chooses Obedient Pet
4) progress as normal until low on money and Emerald's addiction is high
5) Emerald finds the fastest way to make money is to fight the Foxes
6) Lose every fight because of obedient pet, and no money means emerald keeps fighting
7) try to fight back but emerald takes control again if you leave the fox area

Via lucario on discord:
Violet decided to get an always naked band and then Emerald eventually got fed up with being naked and went to go buy clothes for the rest of eternity

Tagssoftlock, Whoredra

Activities

SkyCorp

2021-08-14 05:35

administrator   ~0000112

Second case (reported by lucario) now fixed

First case (reported by stitch-nose), possible solution is for TakeoverActionGetMoney to recognize when opponent can't be hurt and remember it for X turns, then switching to a different method of getting money or bailing on the action entirely (no other method such as sex or selling eggs is consistently available and so bailing out on the takeover action might be the best course).

SkyCorp

2021-08-16 22:31

administrator   ~0000113

Also fixed the first case (reported by stitch-nose)

Issue History

Date Modified Username Field Change
2021-05-04 22:17 SkyCorp New Issue
2021-05-04 22:17 SkyCorp Tag Attached: softlock
2021-05-04 22:17 SkyCorp Tag Attached: Whoredra
2021-05-04 22:17 SkyCorp Status new => acknowledged
2021-08-14 05:35 SkyCorp Assigned To => SkyCorp
2021-08-14 05:35 SkyCorp Status acknowledged => assigned
2021-08-14 05:35 SkyCorp Note Added: 0000112
2021-08-16 22:31 SkyCorp Assigned To SkyCorp =>
2021-08-16 22:31 SkyCorp Status assigned => closed
2021-08-16 22:31 SkyCorp Resolution open => fixed
2021-08-16 22:31 SkyCorp Note Added: 0000113
2021-08-16 22:59 SkyCorp Fixed in Version => r41.3