View Issue Details

IDProjectCategoryView StatusLast Update
0000083The UnderworldBugpublic2022-01-06 05:33
ReporterSkyCorp Assigned To 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Target Versionr42Fixed in Versionr42 
Summary0000083: Game crashes with *lots* of text
Description

Displaying more than 24k characters at a time on the screen leads to an infinite disconnect/reconnect loop.

I don't think this would normally happen, but may impact modders depending on mod.

Steps To Reproduce

Easiest method is to use text editor to spam TFs.

TagsNo tags attached.

Activities

SkyCorp

2022-01-04 06:28

administrator   ~0000122

This is due to hitting maximum packet size, need to implement a packet splitter

System.IO.InvalidDataException: The maximum message size of 32768B was exceeded. The message size can be configured in AddHubOptions.

SkyCorp

2022-01-06 05:33

administrator   ~0000123

Implemented packet splitting + a 100,000 max character limit (enough for ~20,000 words of text in a single scene (plenty!))

Issue History

Date Modified Username Field Change
2021-12-28 02:39 SkyCorp New Issue
2021-12-28 02:40 SkyCorp Status new => confirmed
2022-01-04 06:27 SkyCorp Assigned To => SkyCorp
2022-01-04 06:27 SkyCorp Status confirmed => assigned
2022-01-04 06:28 SkyCorp Note Added: 0000122
2022-01-04 06:30 SkyCorp Target Version => r42
2022-01-06 05:33 SkyCorp Assigned To SkyCorp =>
2022-01-06 05:33 SkyCorp Status assigned => closed
2022-01-06 05:33 SkyCorp Resolution open => fixed
2022-01-06 05:33 SkyCorp Fixed in Version => r42
2022-01-06 05:33 SkyCorp Note Added: 0000123